import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z](?!.*(['-]).*\\1)(?!.* )(?=.{0,19}$)[a-zA-Z'-]*(?: (?<=[a-zA-Z] )[a-zA-Z][a-zA-Z'-]*)*$";
final String string = "This is aa\n"
+ "This is aa test\n"
+ "aa aa aa aa aa aa aa\n"
+ "This should m'atch\n"
+ "This a-lso'\n"
+ "This is a test\n"
+ "a b\n"
+ "aa\n"
+ "a\n\n"
+ "This is 4 test\n"
+ "This is aa test\n"
+ "This' is aa tes\n\n"
+ "This is aaaa longer test\n"
+ "This sh'o'uld not\n"
+ "This sh-o-uld not\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}