re = /^[a-zA-Z](?!.*(['-]).*\1)(?!.* )(?=.{0,19}$)[a-zA-Z'-]*(?: (?<=[a-zA-Z] )[a-zA-Z][a-zA-Z'-]*)*$/m
str = 'This is aa
This is aa test
aa aa aa aa aa aa aa
This should m\'atch
This a-lso\'
This is a test
a b
aa
a
This is 4 test
This is aa test
This\' is aa tes
This is aaaa longer test
This sh\'o\'uld not
This sh-o-uld not
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end