#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\|\|.*\|(?:\R\|\|.*\|)*$"
Local $sString = "|| Responsible | abc|" & @CRLF & _
"|| Departement | def |" & @CRLF & _
"" & @CRLF & _
"|| System A Username | ghi |" & @CRLF & _
"|| Operation | READ |" & @CRLF & _
"|| Page | [Example|http://www.example.com |" & @CRLF & _
"" & @CRLF & _
"|| System B Username | jhk |" & @CRLF & _
"|| Operation | WRITE |" & @CRLF & _
"|| App | helloWorld |"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")