import Foundation
let pattern = #"^\|\|.*\|(?:\R\|\|.*\|)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
|| Responsible | abc|
|| Departement | def |
|| System A Username | ghi |
|| Operation | READ |
|| Page | [Example|http://www.example.com |
|| System B Username | jhk |
|| Operation | WRITE |
|| App | helloWorld |
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)