import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\|\\|.*\\|(?:\\R\\|\\|.*\\|)*$";
final String string = "|| Responsible | abc|\n"
+ "|| Departement | def |\n\n"
+ "|| System A Username | ghi |\n"
+ "|| Operation | READ |\n"
+ "|| Page | [Example|http://www.example.com |\n\n"
+ "|| System B Username | jhk |\n"
+ "|| Operation | WRITE |\n"
+ "|| App | helloWorld |";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}