re = /^\|\|.*\|(?:\R\|\|.*\|)*$/m
str = '|| Responsible | abc|
|| Departement | def |
|| System A Username | ghi |
|| Operation | READ |
|| Page | [Example|http://www.example.com |
|| System B Username | jhk |
|| Operation | WRITE |
|| App | helloWorld |'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end