const regex = new RegExp('^\\|\\|.*\\|(?:\\R\\|\\|.*\\|)*$', 'gm')
const str = `|| Responsible | abc|
|| Departement | def |
|| System A Username | ghi |
|| Operation | READ |
|| Page | [Example|http://www.example.com |
|| System B Username | jhk |
|| Operation | WRITE |
|| App | helloWorld |`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}