package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\|\|.*\|(?:\R\|\|.*\|)*$`)
var str = `|| Responsible | abc|
|| Departement | def |
|| System A Username | ghi |
|| Operation | READ |
|| Page | [Example|http://www.example.com |
|| System B Username | jhk |
|| Operation | WRITE |
|| App | helloWorld |`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}