$re = '/^\|\|.*\|(?:\R\|\|.*\|)*$/m';
$str = '|| Responsible | abc|
|| Departement | def |
|| System A Username | ghi |
|| Operation | READ |
|| Page | [Example|http://www.example.com |
|| System B Username | jhk |
|| Operation | WRITE |
|| App | helloWorld |';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);