#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?-m)(?si)((?:\G(?!^)|<p\b[^>]*>)(?:(?!<\/p>).)*?)[\r\n]+"
Local $sString = "Hola, ahora viene un párrafo" & @CRLF & _
"<p class="lo_que_sea">Estoy " & @CRLF & _
"dentro " & @CRLF & _
"y aquí " & @CRLF & _
"tengo una imagen <img...> " & @CRLF & _
"y sigo con más líneas" & @CRLF & _
"</p>" & @CRLF & _
"Fuera" & @CRLF & _
"<p style="estiloso">" & @CRLF & _
"Otro " & @CRLF & _
"Ejemplo" & @CRLF & _
"</p>" & @CRLF & _
"Fuera del párrafo" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)