import re
regex = re.compile(r"(?-m)(?si)((?:\G(?!^)|<p\b[^>]*>)(?:(?!<\/p>).)*?)[\r\n]+")
test_str = ("Hola, ahora viene un párrafo\n"
"<p class=\"lo_que_sea\">Estoy \n"
"dentro \n"
"y aquí \n"
"tengo una imagen <img...> \n"
"y sigo con más líneas\n"
"</p>\n"
"Fuera\n"
"<p style=\"estiloso\">\n"
"Otro \n"
"Ejemplo\n"
"</p>\n"
"Fuera del párrafo\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)