using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?-m)(?si)((?:\G(?!^)|<p\b[^>]*>)(?:(?!<\/p>).)*?)[\r\n]+";
string substitution = @"\1";
string input = @"Hola, ahora viene un párrafo
<p class=""lo_que_sea"">Estoy
dentro
y aquí
tengo una imagen <img...>
y sigo con más líneas
</p>
Fuera
<p style=""estiloso"">
Otro
Ejemplo
</p>
Fuera del párrafo
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}