import Foundation
let pattern = #"(?-m)(?si)((?:\G(?!^)|<p\b[^>]*>)(?:(?!<\/p>).)*?)[\r\n]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hola, ahora viene un párrafo
<p class="lo_que_sea">Estoy
dentro
y aquí
tengo una imagen <img...>
y sigo con más líneas
</p>
Fuera
<p style="estiloso">
Otro
Ejemplo
</p>
Fuera del párrafo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)