$re = '/(?-m)(?si)((?:\G(?!^)|<p\b[^>]*>)(?:(?!<\/p>).)*?)[\r\n]+/';
$str = 'Hola, ahora viene un párrafo
<p class="lo_que_sea">Estoy
dentro
y aquí
tengo una imagen <img...>
y sigo con más líneas
</p>
Fuera
<p style="estiloso">
Otro
Ejemplo
</p>
Fuera del párrafo
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;