import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?-m)(?si)((?:\\G(?!^)|<p\\b[^>]*>)(?:(?!<\\/p>).)*?)[\\r\\n]+";
final String string = "Hola, ahora viene un párrafo\n"
+ "<p class=\"lo_que_sea\">Estoy \n"
+ "dentro \n"
+ "y aquí \n"
+ "tengo una imagen <img...> \n"
+ "y sigo con más líneas\n"
+ "</p>\n"
+ "Fuera\n"
+ "<p style=\"estiloso\">\n"
+ "Otro \n"
+ "Ejemplo\n"
+ "</p>\n"
+ "Fuera del párrafo\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}