# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<li [^>]*>.*<\\/li>//g;t' <<< "<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
<br><br>
sample text
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
more text
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>"