#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<li [^>]*>.*<\/li>"
Local $sString = "<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>" & @CRLF & _
"<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>" & @CRLF & _
"<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>" & @CRLF & _
"<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>" & @CRLF & _
"<br><br>" & @CRLF & _
" " & @CRLF & _
"sample text" & @CRLF & _
"<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>" & @CRLF & _
"<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>" & @CRLF & _
"" & @CRLF & _
"more text" & @CRLF & _
"<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)