package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<li [^>]*>.*<\/li>`)
var str = `<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>
<br><br>
sample text
<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>
more text
<li class="list-item">aewfaffjpiowfj: apeifjeawpfioj</li>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}