import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<li [^>]*>.*<\\/li>";
final String string = "<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n"
+ "<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n"
+ "<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n"
+ "<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n"
+ "<br><br>\n"
+ " \n"
+ "sample text\n"
+ "<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n"
+ "<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n\n"
+ "more text\n"
+ "<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}