using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<li [^>]*>.*<\/li>";
string substitution = @"";
string input = @"<li class=""list-item"">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=""list-item"">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=""list-item"">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=""list-item"">aewfaffjpiowfj: apeifjeawpfioj</li>
<br><br>
sample text
<li class=""list-item"">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=""list-item"">aewfaffjpiowfj: apeifjeawpfioj</li>
more text
<li class=""list-item"">aewfaffjpiowfj: apeifjeawpfioj</li>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}