// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<li [^>]*>.*<\/li>").unwrap();
let string = "<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
<br><br>
sample text
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>
more text
<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}