import re
regex = re.compile(r"<li [^>]*>.*<\/li>")
test_str = ("<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n"
"<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n"
"<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n"
"<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n"
"<br><br>\n"
" \n"
"sample text\n"
"<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n"
"<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>\n\n"
"more text\n"
"<li class=\"list-item\">aewfaffjpiowfj: apeifjeawpfioj</li>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)