#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(#{1,6}.*)"
Local $sString = "#heading 1 " & @CRLF & _
"bla bla bla" & @CRLF & _
"### heading 3 djdjdj" & @CRLF & _
"bla bla bla" & @CRLF & _
"## heading 2 bal;kasddfas" & @CRLF & _
"fbla bla bla"
Local $sSubst = "<b>$1</b>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)