import re
regex = re.compile(r"^(#{1,6}.*)", flags=re.MULTILINE)
test_str = ("#heading 1 \n"
"bla bla bla\n"
"### heading 3 djdjdj\n"
"bla bla bla\n"
"## heading 2 bal;kasddfas\n"
"fbla bla bla")
subst = "<b>$1</b>"
result = regex.sub(subst, test_str)
if result:
print(result)