package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(#{1,6}.*)`)
var str = `#heading 1
bla bla bla
### heading 3 djdjdj
bla bla bla
## heading 2 bal;kasddfas
fbla bla bla`
var substitution = "<b>$1</b>"
fmt.Println(re.ReplaceAllString(str, substitution))
}