re = /^(#{1,6}.*)/m
str = '#heading 1
bla bla bla
### heading 3 djdjdj
bla bla bla
## heading 2 bal;kasddfas
fbla bla bla'
subst = '<b>$1</b>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result