using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[^>]+src=\\?(?:""|')[^.]+\.gif\\?(?:""|')[^>]*\>";
string input = @"this is <img src=\""test.gif\""/> something with an <img src=\""test.png\""/> in it.
this is <img src=""test.gif""/> something with an <img src=""test.png""/> in it.
this is <img src='test.gif'/> something with an <img src='test.png'/> in it.
this is <img data-test=\"">\"" src=\""test.gif\""/> something with an <img src=\""test.png\""/> in it.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}