// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<img[^>]+src=\\?(?:"|')[^.]+\.gif\\?(?:"|')[^>]*\>"#).unwrap();
let string = "this is <img src=\\\"test.gif\\\"/> something with an <img src=\\\"test.png\\\"/> in it.
this is <img src=\"test.gif\"/> something with an <img src=\"test.png\"/> in it.
this is <img src='test.gif'/> something with an <img src='test.png'/> in it.
this is <img data-test=\\\">\\\" src=\\\"test.gif\\\"/> something with an <img src=\\\"test.png\\\"/> in it.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}