import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img[^>]+src=\\\\?(?:\"|')[^.]+\\.gif\\\\?(?:\"|')[^>]*\\>";
final String string = "this is <img src=\\\"test.gif\\\"/> something with an <img src=\\\"test.png\\\"/> in it.\n"
+ "this is <img src=\"test.gif\"/> something with an <img src=\"test.png\"/> in it.\n"
+ "this is <img src='test.gif'/> something with an <img src='test.png'/> in it.\n"
+ "this is <img data-test=\\\">\\\" src=\\\"test.gif\\\"/> something with an <img src=\\\"test.png\\\"/> in it.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}