$re = '/<img[^>]+src=\\\\?(?:"|\')[^.]+\.gif\\\\?(?:"|\')[^>]*\>/i';
$str = 'this is <img src=\\"test.gif\\"/> something with an <img src=\\"test.png\\"/> in it.
this is <img src="test.gif"/> something with an <img src="test.png"/> in it.
this is <img src=\'test.gif\'/> something with an <img src=\'test.png\'/> in it.
this is <img data-test=\\">\\" src=\\"test.gif\\"/> something with an <img src=\\"test.png\\"/> in it.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);