re = /<img[^>]+src=\\?(?:"|')[^.]+\.gif\\?(?:"|')[^>]*\>/i
str = 'this is <img src=\\"test.gif\\"/> something with an <img src=\\"test.png\\"/> in it.
this is <img src="test.gif"/> something with an <img src="test.png"/> in it.
this is <img src=\'test.gif\'/> something with an <img src=\'test.png\'/> in it.
this is <img data-test=\\">\\" src=\\"test.gif\\"/> something with an <img src=\\"test.png\\"/> in it.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end