package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<img[^>]+src=\\?(?:"|')[^.]+\.gif\\?(?:"|')[^>]*\>`)
var str = `this is <img src=\"test.gif\"/> something with an <img src=\"test.png\"/> in it.
this is <img src="test.gif"/> something with an <img src="test.png"/> in it.
this is <img src='test.gif'/> something with an <img src='test.png'/> in it.
this is <img data-test=\">\" src=\"test.gif\"/> something with an <img src=\"test.png\"/> in it.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}