import Foundation
let pattern = #"<img[^>]+src=\\?(?:"|')[^.]+\.gif\\?(?:"|')[^>]*\>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
this is <img src=\"test.gif\"/> something with an <img src=\"test.png\"/> in it.
this is <img src="test.gif"/> something with an <img src="test.png"/> in it.
this is <img src='test.gif'/> something with an <img src='test.png'/> in it.
this is <img data-test=\">\" src=\"test.gif\"/> something with an <img src=\"test.png\"/> in it.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)