#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<.*?style=.*?)(\s*height.*?;)(.*?>)"
Local $sString = "<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 600px; float:right;">" & @CRLF & _
"" & @CRLF & _
"<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 60%; float:right;">" & @CRLF & _
"<div style="height:50px; width:10px;"></div>" & @CRLF & _
"<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 5em; float:right;">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")