import Foundation
let pattern = #"(<.*?style=.*?)(\s*height.*?;)(.*?>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 600px; float:right;">
<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 60%; float:right;">
<div style="height:50px; width:10px;"></div>
<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 5em; float:right;">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)