package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<.*?style=.*?)(\s*height.*?;)(.*?>)`)
var str = `<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 600px; float:right;">
<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 60%; float:right;">
<div style="height:50px; width:10px;"></div>
<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 5em; float:right;">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}