// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<.*?style=.*?)(\s*height.*?;)(.*?>)").unwrap();
let string = "<img src=\"http://hello-world/img/a1.jpg\" style=\"width: 800px; height: 600px; float:right;\">
<img src=\"http://hello-world/img/a1.jpg\" style=\"width: 800px; height: 60%; float:right;\">
<div style=\"height:50px; width:10px;\"></div>
<img src=\"http://hello-world/img/a1.jpg\" style=\"width: 800px; height: 5em; float:right;\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}