import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<.*?style=.*?)(\\s*height.*?;)(.*?>)";
final String string = "<img src=\"http://hello-world/img/a1.jpg\" style=\"width: 800px; height: 600px; float:right;\">\n\n"
+ "<img src=\"http://hello-world/img/a1.jpg\" style=\"width: 800px; height: 60%; float:right;\">\n"
+ "<div style=\"height:50px; width:10px;\"></div>\n"
+ "<img src=\"http://hello-world/img/a1.jpg\" style=\"width: 800px; height: 5em; float:right;\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}