$re = '/(<.*?style=.*?)(\s*height.*?;)(.*?>)/m';
$str = '<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 600px; float:right;">
<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 60%; float:right;">
<div style="height:50px; width:10px;"></div>
<img src="http://hello-world/img/a1.jpg" style="width: 800px; height: 5em; float:right;">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);