import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?://(?:www\\.)?youtu(?:be\\.com/watch\\?v=|\\.be/))?([a-zA-Z0-9_\\-+?:]+)/?";
final String string = "http://youtube.com/watch?v=slBEtqC_JsI\n"
+ "http://youtube.com/watch?v=slBEtqC_JSJ/\n"
+ "https://youtu.be/bOxza0rLv1o";
final String subst = "https://i.ytimg.com/vi/$1/hqdefault.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}