// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:https?://(?:www\.)?youtu(?:be\.com/watch\?v=|\.be/))?([a-zA-Z0-9_\-+?:]+)/?").unwrap();
let string = "http://youtube.com/watch?v=slBEtqC_JsI
http://youtube.com/watch?v=slBEtqC_JSJ/
https://youtu.be/bOxza0rLv1o";
let substitution = "https://i.ytimg.com/vi/$1/hqdefault.jpg";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}