$re = '~(?:https?://(?:www\.)?youtu(?:be\.com/watch\?v=|\.be/))?([a-zA-Z0-9_\-+?:]+)/?~';
$str = 'http://youtube.com/watch?v=slBEtqC_JsI
http://youtube.com/watch?v=slBEtqC_JSJ/
https://youtu.be/bOxza0rLv1o';
$subst = "https://i.ytimg.com/vi/$1/hqdefault.jpg";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;