# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:https?://(?:www\.)?youtu(?:be\.com/watch\?v=|\.be/))?([a-zA-Z0-9_\-+?:]+)/?"
test_str = ("http://youtube.com/watch?v=slBEtqC_JsI\n"
"http://youtube.com/watch?v=slBEtqC_JSJ/\n"
"https://youtu.be/bOxza0rLv1o")
subst = "https://i.ytimg.com/vi/$1/hqdefault.jpg"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.