import Foundation
let pattern = #"(?:https?://(?:www\.)?youtu(?:be\.com/watch\?v=|\.be/))?([a-zA-Z0-9_\-+?:]+)/?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://youtube.com/watch?v=slBEtqC_JsI
http://youtube.com/watch?v=slBEtqC_JSJ/
https://youtu.be/bOxza0rLv1o
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://i.ytimg.com/vi/$1/hqdefault.jpg"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)