const regex = new RegExp('(?:https?://(?:www\\.)?youtu(?:be\\.com/watch\\?v=|\\.be/))?([a-zA-Z0-9_\\-+?:]+)/?', 'g')
const str = `http://youtube.com/watch?v=slBEtqC_JsI
http://youtube.com/watch?v=slBEtqC_JSJ/
https://youtu.be/bOxza0rLv1o`;
const subst = `https://i.ytimg.com/vi/$1/hqdefault.jpg`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);