re = /(?:https?:\/\/(?:www\.)?youtu(?:be\.com\/watch\?v=|\.be\/))?([a-zA-Z0-9_\-+?:]+)\/?/
str = 'http://youtube.com/watch?v=slBEtqC_JsI
http://youtube.com/watch?v=slBEtqC_JSJ/
https://youtu.be/bOxza0rLv1o'
subst = 'https://i.ytimg.com/vi/$1/hqdefault.jpg'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result