#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z]{3}-[0-9]{4}((?:\s[\w-]+)*)"
Local $sString = "|Placa:AVX-4300 Fiat Uno |" & @CRLF & _
"|Placa:AVX-4300 Fiat Uno Modelo 2010|" & @CRLF & _
"|Placa:AVX-4300 Fiat Uno Modelo 2010 Ano 2011|" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")