import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{3}-[0-9]{4}((?:\\s[\\w-]+)*)";
final String string = "|Placa:AVX-4300 Fiat Uno |\n"
+ "|Placa:AVX-4300 Fiat Uno Modelo 2010|\n"
+ "|Placa:AVX-4300 Fiat Uno Modelo 2010 Ano 2011|\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}