using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{3}-[0-9]{4}((?:\s[\w-]+)*)";
string input = @"|Placa:AVX-4300 Fiat Uno |
|Placa:AVX-4300 Fiat Uno Modelo 2010|
|Placa:AVX-4300 Fiat Uno Modelo 2010 Ano 2011|
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}