re = /[A-Z]{3}-[0-9]{4}((?:\s[\w-]+)*)/
str = '|Placa:AVX-4300 Fiat Uno |
|Placa:AVX-4300 Fiat Uno Modelo 2010|
|Placa:AVX-4300 Fiat Uno Modelo 2010 Ano 2011|
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end